PowerSDR and CW skimmer CAT interfacing problem - "Radio is not responding"
FlexRadio Systems Forums
Home       Members    Calendar    Who's On
Welcome Guest ( Login | Register )
        


PowerSDR and CW skimmer CAT interfacing... Expand / Collapse
Author
Message
Posted Saturday, February 18, 2012 4:22 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: Forum Members
Last Login: Saturday, February 18, 2012 3:42 AM
Posts: 1, Visits: 1
I have Flex3000 and I am running PowerSDR v2.2.3 and CW skimmer 1.71. I have Eterlogic Virtual Serial Ports Emulator 0.938.4.846. (VSPE)

I have a problem with CW Skimmer CAT control. The bottom left corner radio icon is red and when you hover mouse cursor on the icon you get message "Radio is not responding".
I have tried many different configurations and done quite a lot of Google searching to find a solution without luck. Based on VSPE monitoring I can see that serial communication is working, as messages get send and response comes back.

Looking at VSPE info screen on COM5 <=> COM15 pair I can see that PowerSDR is using COM15 (as configured) and CW skimmer is using COM5 (Omnirig.exe as configured).
CW Skimmer sends command "AI0;" (in hex 41 49 30 3B ) and PowerSDR responds with "?;" (in hex 3F 3B).

If I turn on "Allow Kenwood AI command" flag on PowerSDR CAT control panel, this response message "?;" does not appear. Using the TEST button on PowerSDR CAT control panel I get the same response behavior if I manually enter the "AI0;" command.

I have tested different combinations on CW Skimmer / CAT interface / Omni-rig settings (rig types PowerSDR / Kenwood / TS-2000 / TS-480) and PowerSDR CAT settings (ID as PowerSDR / TS-2000/TS-480) as well as changing speed (4800/9600/57600), RTS/DTS settings etc. combinations.

I have tried also DDUtil and few other software packages and I am pretty convinced that problem is not in COM port to COM port communication but this is some other higher level CAT protocol configuration issue. I have also tested the exact configurations in the Flex Support pages without luck. I am stuck with this problem.

Has anybody got CW Skimmer and PowerSDR talking to each other via CAT interface?



  Post Attachments 
Capture1.PNG (14 views, 36.30 KB)
Capture2.PNG (10 views, 37.62 KB)
Post #5415
Posted Tuesday, May 22, 2012 7:15 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: Forum Members
Last Login: Saturday, December 1, 2012 12:20 PM
Posts: 2, Visits: 8
Hello! I don't know if you solved the problem but I came on same problem and figure it out.

The problem is that it doesn't work in VSPE with PAIR virtual serial cable but you must

1. create Connector
2. create Splitter

With this kind of configuration I managed to use CWskimmer + Flexradio and CAT.

73,
Goran ANDRIC, S55OO
Post #5693
« Prev Topic | Next Topic »

Reading This Topic Expand / Collapse
Active Users: 1 (1 guest, 0 members, 0 anonymous members)
No members currently viewing this topic.

Permissions Expand / Collapse

All times are GMT -5:00, Time now is 5:05am

Powered By InstantForum.NET v4.1.4 © 2020
Execution: 0.031. 11 queries. Compression Disabled.