Intermittent raspy audio in VU-5K
FlexRadio Systems Forums
Home       Members    Calendar    Who's On
Welcome Guest ( Login | Register )
        


Intermittent raspy audio in VU-5K Expand / Collapse
Author
Message
Posted Friday, July 8, 2011 9:04 AM
Junior Member

Junior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior Member

Group: Forum Members
Last Login: Thursday, July 9, 2015 2:23 PM
Posts: 11, Visits: 25
The raspy audio I am referencing is the same as you sometimes hear the first time you install a new PowerSDR version and run it for the first time. If you cycle the start button, it goes away. In my case, it occurs very erratically afterwards. I used an old XP machine, and found that if I ran the Firewire at Safe Mode Level 2 it did not happen. The latency numbers sometimes spiked badly, so I didn't worry about it.

However, I now have a new machine with far better performance. Typical latency in around 70 us, and the absolute max recorded is 301 us. Yesterday I was surprised to have this happen again. It was also on the TX audio as well. The person I was talking with said I started "splattering like crazy." It was set at Safe Mode Level 1, using the RC3. As before, cycling the PowerSDR cleared the problem. It has not happened again, but I would like to fix the problem. I sometimes run modes like WSPR where you don't necessarily have the audio up, and it would make a real mess if it happened again. I have not dropped back to the production version of PowerSDR, but when I was using my old machine I did, and there was no improvement. It was much easier to duplicate there.

There is a lot of info in the KB on dropouts, but I didn't see anything on raspy audio. Before I start fiddling around with buffers, etc, is this a form of audio dropout, or should I be looking at something else?

Alan
WA4SCA
Post #4602
Posted Friday, July 8, 2011 4:16 PM
Supreme Being

Supreme BeingSupreme BeingSupreme BeingSupreme BeingSupreme BeingSupreme BeingSupreme BeingSupreme Being

Group: Forum Members
Last Login: Tuesday, August 13, 2013 12:47 AM
Posts: 109, Visits: 274
Alan,

Usually the raspy audio, some called distorted audio is due to computer resources not getting back to keep the RX/TX threaded buffered correctly, and simply Stopping/Starting the radio (with the Start button) will re-sync the buffers. Even with low CPU and DSP numbers, there are spikes that will cause these to get out of sync, so you need to look at resources.. Now with Vista and Win7 it is really important to have the Power Options in the Windows Control panel to be set at High Perforance. Not Balanced, which is Windows default setting.

Hope this helps

73,

Dudley

FlexRadio Systems Support
512-535-4713, Option 2
http://helpdesk.flexradio.com

Post #4606
Posted Friday, July 8, 2011 4:48 PM
Junior Member

Junior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior Member

Group: Forum Members
Last Login: Thursday, July 9, 2015 2:23 PM
Posts: 11, Visits: 25
Dudley,

It does indeed help. The power setting was set to High Performance when I got the computer. I checked. However, it was Balanced when I checked again just now. In between, I transferred some settings and programs from the old machine. Not WIN7 as this one is, but more than a few settings got set to unexpected values. As always, thanks for the great Flex support!

Alan
WA4SCA
Post #4607
Posted Wednesday, August 24, 2011 9:24 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: Forum Members
Last Login: Wednesday, August 24, 2011 9:16 PM
Posts: 1, Visits: 1
This thread is getting fairly old, but in case you still have the problem or for others that may come across this...

Check the DPC Latency.  I was able to get rid of most of the raspy audio with Safe Mode 2.

Then I googled DPC Latency and Windows 7 (my OS) and found an article that cleared up my problem 99%.  In my case, the processor is an Intel Dual Core 5000 series with the Intel Stepping feature.  Yep, you guessed it - it was that darn stepping feature.  I turned it off in BIOS and no more distortion and I can run in normal mode.  Only once have I had a slight issue and that was in CW mode after leaving the Flex 5000 on all night.

YMMV but it has worked for me.

Post #4759
« Prev Topic | Next Topic »

Reading This Topic Expand / Collapse
Active Users: 0 (0 guests, 0 members, 0 anonymous members)
No members currently viewing this topic.

Permissions Expand / Collapse

All times are GMT -5:00, Time now is 9:57am

Powered By InstantForum.NET v4.1.4 © 2018
Execution: 0.031. 8 queries. Compression Disabled.